Video im Player wiedergeben



  • Moin,

    Ich wollte im Wiki ganz kurze Anleitungsvideos als .mp4 hochladen.
    Chrome: Der Player öffnet auch ein Fenster und spielt Ton, aber kein Bild.
    Firefox: Öffnet den Player, aber spielt das Video nicht an
    Edge: zeigt das Video

    Woran kann das liegen? Sind das Einstellungen im Browser, oder liegt das am Player?

    Gruß, Simon


  • admin

    Wir haben das gleiche Problem mit avi Dateien.

    Safari öffnet auch den Player, spielt aber nicht ab



  • Ich würde das Video einfach bei Youtube einstellen und dann bei uns integrieren.
    Man spart sich den speicherplatz und die kümmern sich um den Player ...

    Und man kann die Privatsphäreeinstellungen des Videos bei Youtube ja so einstellen, dass es sonst niemandem gezeigt wird.



  • wir arbeiten auch so. Video bei YouTube einstellen, Privat. Dann per iFrame einbinden.


  • admin

    Haben wir jetzt auch so gelöst. Bleibt aber dennoch ein Bug ;)


  • admin

    Wobei ich gerade sehe, dass es gar nicht unter Fehlermeldung steht...



  • @simfae: Das ist ein Browserproblem. Das einfachste ist, ein Video von "extern" einzubinden. Wenn du dennoch Videos von deinem Server laden willst, musst du das in drei Versionen tun.

    1. ".mp4" für den Safari Brwoser und Mac-Geräte
    2. ".ogv" oder ".ogg" für Opera u.a.
    3. ".webm" für bspw. Chrome.
      Das Ganze muss dann als HTML5 Video eingebunden werden. Momentan geht das bei CT nur durch einzelne iframe-Einbindung. Ich glaube html5 tags sind noch nicht erlaubt.
      Weitere infos zur Kompatibilität mit den Formaten und zur Einbindung unter: HTML5 Video bei W3Schools


  • Danke für die Hinweise. Ich werde dann den Weg über private youtube Videos gehen. Das klingt am vernünftigsten...



  • @daniel_h h.264 (im mp4 Container) kann mittlerweile prinzipiell von allen gebräuchlichen Browsern wiedergegeben werden. Teilweise greifen die zwar auf den System-Codec zurück, aber zumindest unter Windows sollte der immer da sein.
    Und im Notfall bleibt noch der FlashPlayer, der kann auch h.264.

    Man kann also einen Player bauen, der fast überall funktioniert.



  • Moin,
    Ich muss nochmal auf dieses Thema zurück kommen. Hab nun youtube Videos per iFrame im Wiki eingebettet. Klappt sehr gut. Allerdings ist die Vollbildanzeige im Player nicht verfügbar. Das stört mich noch ein bisschen. Ich habe bisher nur erfolglos versucht das über die Url Parameter zu lösen.
    Habt ihr das gleiche Problem?
    Gibt es eine Möglichkeit die Parameter für das iFrame so zu editieren, dass der Vollbildmodus erlaubt ist?

    Danke,
    Simon



  • @simfae : In den I-frame-Klammern muss "allowfullscreen" drin stehen
    Beispielcode width="640" height="360" src="https://www.youtube.com/embed/1x0PUMMz4zY" frameborder="0" allowfullscreen
    Zum hübsch machen im Wiki an den Videolink folgendes anhängen:
    rel=0 um teilweise völlig artfremde vorgeschlagene Videos am Ende zu unterbinden
    showinfo=0 Videotitel ausblenden

    Bsp: https://www.youtube.com/embed/1x0PUMMz4zY?rel=0&showinfo=0

    Grüße Daniel



  • @daniel_h warum ging die Antwort an mich? Betrifft das nicht eher den Post von @simfae ?



  • @hallo144: Sorry du hast Recht. Die Antwort ging an @simfae.



  • @hallo144: Nochmal zu deinem Thema: Ob man jetzt den Internet Explorer als gebräuchlichen Browser bezeichnet sei dahingestellt (bei uns leider noch sehr häufig benutzt), aber dort wird nach wie vor kein AVCHD/H.264 unterstützt, selbst wenn der Codec unter Windows installiert ist. Das meinte ich damit. Und der Flash Player nützt dir da auch nichts, weil der ja nur Flashvideos abspielt. Und wenn ich eine flv-Datei bereistelle, dann spielt ja ein Browser ohne Flash den Inhalt nicht ab. Deshalb hatte ich ja das mit den unterschiedlichen Typen oben erläutert, oder man nimmt ganz einfach ein Youtube-Embedding.



  • @daniel_h Der Adobe FlashPlayer kann schon sehr lange auch h.264 wiedergeben, es genügt also eine Datei für alles.

    AVCHD basiert zwar auf h.264, ist aber nicht das gleiche. Dieser Codec wird eigentlich nur als Aufnahme-Codec in Videokameras genutzt. Zur Veröffentlichung im Netz ist der nicht gedacht und wird meines Wissens auch von keinem Browser unterstützt.

    ich arbeite auch bei einem lokalem Fernsehsender mit und da bespielen wir alle Browser mit einer Datei (h.264 im mp4 Container). Bevorzugt wird html5, es gibt aber auch nen Flash-Fallback.
    Erstellt wird das Video wird das ganze mit libav, wo auch skaliert und das Logo eingefügt wird.

    Der Player basiert auf mediaelement.js (z.B. auch der Standard Wordpress-Player) und wurde von uns noch um weitere Steuerfunktionen erweitert. Es sollte also möglich sein, diesen Player auch ein ChurchTools einzubinden.

    Du kannst dir das ganze mal hier anschauen. Ich habe es gerade nochmal mit IE11 und Edge getestet und bei beiden war die direkte Wiedergabe möglich.

    Falls noch weitere Fragen sind, stehe ich gerne zur Verfügung.


  • admin

    Sorry ... kann mir mal hier kurz jemand mit einem ausgefüllten Fenster für Youtube auf die Sprünge helfen?

    0_1472585577497_Unbenannt.png

    Habe in anderen Systemen schon 1000x YT-Iframes eingebunden, aber hier funzt es gerade überhaupt nicht. :(
    Und ich bin mir sicher, dass ich das zu Testzwecken schon mal hinbekommen hatte... bin gerade etwas vernagelt.

    Wäre ggf. auch hilfreich, wenn das hier in der Doku beispielhaft aufgeführt wäre.



  • @Andy Bei uns klappt das so:
    0_1472633267373_31-08-_2016_10-45-33.png

    Wichtig ist aber, dass bei den Videoeinstellungen in YouTube die externe Einbindung zugelassen wird.


  • admin

    @seetalchile Ok, vielen Dank, werde ich testen.



  • @Andy Übrigens: Die URL nehmen wir bei YouTube jeweils von hier (keine Ahnung, ob es mit dem "normalen" Link auch klappen würde):
    0_1472636637275_31-08-_2016_11-42-12.png


  • admin

    @seetalchile Daran liegt es ggf. Hatte verschiedene Varianten ausprobiert, aber genau das wohl nicht. Ich teste es nachher mal.


  • admin

    Das klappt schon ... aber wie gebe ich das 'allowfullscreen' mit?


  • admin

    Möchte nochmals fragen, wie ich die Schaltfläche zur Vollbilddarstellung (allowfullscreen) aktivieren kann, ohne den Umweg über den YT-Link gehen zu müssen?



  • @Andy Dazu kann ich leider momentan auch nicht mehr sagen. Es "allowfullscreen" scheint ein spezifisches Attribut von YouTube zu sein und kann beim iFrame-Generator in ChurchTools nicht angegeben werden. Und einen beliebigen HTML-Text kannst du auch nirgends einfügen...

    Ich mache die Clips jeweils einfach genügend gross (width/height). Und auf Smartphones werden diese ohnehin immer im Vollbildmodus abgespielt.


Anmelden zum Antworten
 

Es scheint als hättest du die Verbindung zu ChurchTools Forum verloren, bitte warte während wir versuchen sie wieder aufzubauen.