Neue Version 2.47 steht nun bereit!


  • ChurchToolsMitarbeiter

    Achtung: Mindestanforderung ist nun auf PHP>=5.3 gestiegen!
    Empfehlenswert ist PHP ab 5.3.17, denn dadurch werden nun Salted-Passwörter verwendet.

    Infos nun hier:
    https://intern.churchtools.de/#WikiView ... changelog/



  • Hallo,

    wir wollten von 2.43 auf 2.47 updaten. Nach austauschen des "system"-Ordners kam folgende meldung:
    Fatal error: Call to a member function getText() on a non-object in /var/www/web513/html/churchtools/system/churchcore/churchcore_db.inc on line 556
    Haben wir etas vergessen?

    https://intern.churchtools.de/?q=help&d ... tallation/ -> Einspielen von Updates war unsere Anleitung.

    Danke der Hilfe.

    (Natürlich haben wir wieder zurückgefahren und das System läuft nun wieder auf 2.43)


  • ChurchToolsMitarbeiter

    Dazu zwei Fragen:

    1. Kam die Meldung immer oder nur einmalig beim Update?
    2. Hast Du wirklich alle neuen Dateien&Ordner im System-Ordner hochkopiert? Vielleicht hast Du den neuen "lib"-ordner vergessen?


  • Ich habe auch eine Fehlermeldung, er lädt die Seite, zeigt aber ne Fehlermeldung an (wie so ein pop up) und will die Seite neu laden.
    v.2.44 auf 2.47

    Fehlermeldung: 200 parsererror Fehler: SyntaxError: Unexpected token <

    Warning: json_encode() expects exactly 1 parameter, 2 given in churchtools/system/churchcore/churchcore_db.inc on line 1020
    [ERROR] file:churchtools/system/churchcore/churchcore_db.inc:1020
    json_encode() expects exactly 1 parameter, 2 given


  • ChurchToolsMitarbeiter

    @Josch: Das liegt daran, dass Du nicht PHP 5.3 hast. Wie in der Changelog.txt zu lesen, ist PHP 5.3 nun Systemanforderung!



  • Ok vielen Dank für die schnelle Hilfe.

    Edit:
    Für euch die ihr vielleicht das selbe Problem habt, es ist wichtig das ihr in der .htaccess datei
    AddType x-mapp-php5.4 .php
    AddHandler x-mapp-php5.4 .php
    oder höher eintragt, da wenn dort nur 5 oder noch etwas von 4 steht Churchtools eine Fehlermeldung ausspuckt.
    (gilt nur bei Linux servern)
    LG


  • ChurchToolsMitarbeiter

    Das gilt nicht für jeden Linux-Server, sondern nur wo er nicht standardmäßig auf PHP>=5.3 eingestellt ist. Also anscheinend z.B. bei 1&1.


Log in to reply