Telegram integration läuft nicht



  • Hallo Community

    Ich habe heute mit Freude gelesen, dass es eine Telegram-Integration für Churchtools gibt. Sogleich wollte ich das mal ausprobieren, musste aber ernüchtert feststellen das es leider nicht funktioniert. :-(

    Ich kriege jeweils nur die Fehlermeldung "Bot nicht erreichbar, bitte später versuchen."

    Hat das mit meinen Einstellungen zu tun, oder funktioniert der Bot momentan nicht? Ich habe nur in diversen Beiträgen gelesen, dass er noch in der Testphase ist.
    In den ChurchDB Einstellungen habe ich als API-Key für cmtelecom.com "abc" eingegeben, wie im Wiki angegeben.

    Liebe Grüsse
    Urs



  • Hallo Urs,

    ich habe die Integration gerade ausprobiert und ich konnte keinen Fehler feststellen...

    Hast du unter https://kurzname.churchtools.de/?q=telegram den Zugang gestartet?

    Viele Grüße
    Anja



  • Ich hab's eben auch erstmalig getestet, aber leider gibt es keine Freigabe mit dem angezeigten Code. Der Bot antwortet nur "Sorry, da hat was nicht geklappt. Am besten mit /stop erneut verbinden". Hab das mehrmals auch mit unterschiedlichen Zugangcodes probiert...



  • @abolay
    Hallo Anja,
    eben dabei happerts schon... Ich nehme mal an, dass ich die URL einfach auf meine Churchtools Domain anpassen muss und dann einfach das ?q=telegramm anhänge. Wenn ich das mache, dann kriege ich eben nach einer Weile "Sanduhr" die besagte Meldung. Heute kriege ich immer noch die gleiche Meldung wie gestern. Ich kann mir den Zugang also gar nicht freischalten.

    Kann es eventuell doch sein, dass es nicht geht, weil ich bei cmtelecom.com kein Account habe? Oder geht es nur aus Deutschland? (Was für mich allerdings keinen Sinn ergeben würde...)

    Übrigens ich bin Selfhoster am Testen und habe sonst noch nichts freigeschaltet, falls das von Bedeutung sein könnte...

    Grüsse
    Urs



  • @abolay @Joe999 Ich bin auch selfhoster und bei mir läuft der Bot wie am Schnürchen. Es hat bei mir erst geklappt, nachdem ich mir einen richtigen API-Key von cmtelecom geholt habe. Mit abc oder ähnlichem hat es bei mir nicht funktioniert. Außerdem musst du für die User, die Telegram benutzen können sollen die "Nutzung SMS Schnittstelle" als Recht in der Rechteverwaltung freischalten. Anschließend wie @abolay geschrieben hat den Bot starten.



  • Hm, wir hosten nicht selbst. Als API-Key für cmtelecom.com habe ich "abc" eingetragen.



  • Hier ist das gleiche Problem... wir haben die Integration schon lange nicht mehr geprüft, zur Zeit bekomme ich keinen neuen "Kontakt" zum Bot. Das Pairing nach der Code-Eingabe im Bot hängt. Bis dahin läuft alles wie gewohnt... :(


Log in to reply