LDAP Benutzername mit @ und Domain



  • Hallo,
    ich habe gestern erfolgreich den LDAP-Wrapper von @milux zum Laufen gebracht. An dieser Stelle erstmal vielen Dank dafür!
    Ziel ist es, dass sich unsere Mitarbeiter auch mit den Daten bei Wordpress einloggen können. Über das in der CT-Hilfe verlinkte Plugin klappt das auch ohne Probleme. Jedoch ist dort die Verknüpfung mit den Gruppen nur in der 99€ teuren Premium Version enthalten. Deshalb habe ich ein anderes Plugin gefunden (das hier).
    Mein Problem ist jetzt, dass ich da nicht durch die Konfiguration komme. Es wird ein Benutzername im Format "administration@test.ad" benötigt. Ich habe schon einige Kombinationen ausprobiert, finde dafür nicht die richtige Lösung. Könnte mir da jemand weiterhelfen?
    Danke!
    0_1548321962341_2019-01-24_10-23-52.png



  • Hallo,

    ich nutze das in der Hilfe verlinkte Plugin.
    Scheinbar hatte die Version als ich sie damals eingerichtet hatte einen Bug,
    denn da ging es mit den Gruppen auch ohne Bezahlung. Oder da war es noch kostenlos enthalten.
    Ändern kann ich dies jedenfalls nun nur noch gegen Zahlung -.-
    Deshalb würde ich mich freuen wenn du das Plugin nach einem Test "bewerten" könntest, dann steige ich ggf. auch um.

    Folgende Anmeldedaten verwende ich dort:
    0_1548351853883_f2059e40-526d-4165-a66a-67ece47b1d4f-image.png

    In der ctldap.config steht bei mir "ldap_user=root" und "ldap_base_dn=churchtools"

    Aus dem Hilfetext von diesem Plugin ([...]Username@domainname[...]) würde ich also folgende Schreibweise vermuten:
    root@churchtools bzw generell ldap_user@ldap_base_dn

    Das könntest du also mal versuchen.

    //Edit: Ich glaube außerdem, dass dein Base DN falsch ist. Meiner sieht glaub so aus:
    cn=cmsuserid,ou=users,o=churchtools

    Gruß Daniel



  • @koehdaniel sagte in LDAP Benutzername mit @ und Domain:

    Aus dem Hilfetext von diesem Plugin ([...]Username@domainname[...]) würde ich also folgende Schreibweise vermuten:
    root@churchtools bzw generell ldap_user@ldap_base_dn

    das wäre bei mir auch "root@churchtools", was ich bereits ausprobiert habe

    @koehdaniel sagte in LDAP Benutzername mit @ und Domain:

    Ich glaube außerdem, dass dein Base DN falsch ist. Meiner sieht glaub so aus:
    cn=cmsuserid,ou=users,o=churchtools

    ich hatte meinen Base DN eigentlich aus dem Readme von GitHub, das hat bei dem Plugin, das du nutzt auch gut funktioniert. Nur bei diesem werden zwingend zwei DN-Attribute gefordert, deshalb hab ich das etwas umgestellt.

    Ich werde mich mal mit dem Entwickler des Plugins in Verbindung setzen, viellt bekomme ich da Hilfe. Ansonsten mache ich mich auf die Suche nach einem anderen Plugin...



  • Hälst du uns dann auf dem Laufenden wenn es etwas neues gibt?



  • @samu95 wie hast du es jetzt im Endeffekt gelöst?

    Gruß Daniel



  • Bin da leider noch nicht weiter gekommen. War im letzten Monat mit anderen Dingen beschäftigt. Werde das aber demnächst klären und dann Bescheid geben


Log in to reply