[Wiki] Schlechte Performance



  • Wir haben seit einigen Tagen unseren bisherigen internen Bereich vollständig mit ChurchTools abgelöst.
    Dazu gehören z.B. auch ein Download-Bereich oder eine Bildergalerie.
    Allerdings fällt auf, dass die Performance gerade im Wiki extrem langsam ist. Liegt das evtl. an der Verschlüsselung (an der Galerie liegt's nicht, die lädt auch nicht schneller/langsamer als der Rest)?
    Ich verstehe ohnehin nicht, weshalb hier eine Verschlüsselung erfolgt. Die anderen Daten sind doch mindestens genau so brisant.
    Wir arbeiten mit SSL, das sollte genug Sicherheit bieten.

    Könnte die spezielle Verschlüsselung im Wiki nicht als Option angeboten werden?


  • admin

    @hja Hm ... gerade mal bei uns getestet ... allerdings nur mit PDFs. Geht alles rasant flott.



  • @hja Hallo, wir planen ChurchTools für unsere Gemeinde einzusetzen und sind ganz glücklich darüber, dass das Wiki verschlüsselt ist. Wir planen dort recht viele detaillierte Informationen über das Gebäude, interne Abläufe und teilweise auch Zugangsdaten zu hinterlegen. Liegen die Daten verschlüsselt auf dem Server ist eine Sicherheitsstufe mehr drin, als wenn sie unverschlüsselt dort wären.


  • ChurchToolsMitarbeiter

    Die Verschlüsselung kann eigentlich nicht der Grund sein. Wir haben wirklich viele Daten im Wiki und es läuft auch alles schnell.
    Hostet Ihr selber? Dann schaut doch mal hier letztes Kapitel
    https://intern.churchtools.de/?q=churchwiki#WikiView/filterWikicategory_id:0/doc:Installation/



  • @jmrauen die schlechte Performance ist nicht bei allen Wiki-Seiten zu beobachten. Besonders schlechte Performance fällt auf bei Wiki-Seiten mit (kleinen) Vorschaubildern. Die sind mit base64 und als Plain-Text codiert (data:image/png;base64,iVBORw0KGgoAAAA...).
    Scheint so, dass die Codierung der Bilder für die schlechte Performance verantwortlich ist. Kann das sein?


  • ChurchToolsMitarbeiter

    Ah so, das kann sein. Das ist so nicht vorgesehen und macht die Dateigröße im Wiki dann sehr groß. Bilder sollten als Datei an das Dokument jeweils anhängt und dann mit Bild einfügen hinzugefügt werden.



  • @jmrauen verstehe ich nicht ganz. Wie kann ich ein Bild als Datei an ein Dokument anhängen? Ist das so gemeint, dass ich das Bild hochladen u. dann die URL angeben soll? Und wohin kann ich das Bild dann hochladen (gibt's dafür eine Art image-Folder innerhalb CT)?



  • @jmrauen kannst du bt. nochmal kurz erklären, wie ich das machen kann? Ist das so gemeint, dass ich das Bild hochladen u. dann die URL angeben soll? Und wohin kann ich das Bild dann hochladen (gibt's dafür eine Art image-Folder innerhalb CT)?


  • admin

    @hja Gemeint ist sicher der normale File-Upload innerhalb des Wiki. Dann den Link kopieren und entsprechend im Text einfügen.



  • @Andy eher nicht. Ich zitiere jmrauen: Das ist so nicht vorgesehen und macht die Dateigröße im Wiki dann sehr groß. Bilder sollten als Datei an das Dokument jeweils anhängt und dann mit Bild einfügen hinzugefügt werden.

    Es geht um die schlechte Performance bei Bildern. Ich verstehe das so, dass die Bilder durch einfaches Einfügen die schlechte Performance bringen. Die müssen wohl anders eingefügt werden.


  • admin

    @hja Ich habe es so verstanden, dass das eine Lösung von dir ist, die nicht vorgesehen ist:

    Die sind mit base64 und als Plain-Text codiert



  • @Andy ja, so hab ich das auch verstanden (ist mit Cut&Paste eingefügt). Meine Frage ist jetzt, wie ich Bilder korrekt einfügen kann.
    Idee: in einem CT-Verzeichnis ablegen, dann im Wiki Bild einfügen mit entsprechender URL.
    --> ist das so richtig u. ist dafür ein Verzeichnis vorgesehen?


  • admin

    @hja nein, gedacht ist es in den CT anders: Bilder als Anlage im Wiki hochladen; so hat @jmrauen das in seinem o. g. Post gemeint.



  • @Andy ich versuch unser Problem nochmal zu verdeutlichen:

    1. wir haben eine Download-Startseite im Wiki
      Auf dieser Seite sind die besagten Bilder mit der schlechten Performance.
    2. Durch Klick auf den gewünschten Bereich landen unsere Leute dann auf der jeweiligen Download-Seite.

    Es hilft also nichts, wenn ich Bilder als Anlage hochlade. Die wären dann ja so nicht sichtbar.


  • admin

    @hja doch, doch ... du kannst sie dann natürlich im Text einfügen:

    0_1456570484961_Bildschirmfoto vom 2016-02-27 11:52:36.png

    So war das oben gemeint ...



  • @Andy ah, jetzt steige ich langsam dahinter.
    Versuche mal zu rekapitulieren:

    1. Wiki-Bereich, in dem die Bilder als Anlagen hochgeladen werden.
    2. Link kopieren und
    3. dann einfügen.

    Könnten wir die Bilder anstelle Wiki-Anlage nicht in einem CT-Verzeichnis ablegen u. dorthin verlinken?


  • admin

    @hja Korrekt! :D

    Die Anlagen kannst du außerdem verstecken, so dass sie nur die Personen sehen, die Schreibrechte haben. Die verlinkten Bilder sind dann trotzdem für alles leseberechtigten sichtbar.



  • @Andy ok, danke. Jetzt hab ich das (endlich) verstanden.
    Gibt's auch die andere Variante (also FTP-Verzeichnis mit Bildern)?


  • admin

    @hja :+1:
    Nee, die files werden ja verschlüsselt.
    Mein Screenshot mit den FTP-Daten war nur ein Beispiel aus einer Doku, die für das MP3-Team bei uns im Wiki abgelegt ist. Hatte auf die Schnelle kein anderes Beispiel mit eingebundenem Bild parat. ;-)



  • alles klar. Habe die Empfehlungen umgesetzt - und das Wiki schnurrt wieder ...
    Danke!


  • admin

    @hja Vielleicht noch ein kleiner Tipp: Wenn du bei der Bild-URL alles vor dem '?' weglässt, dann überlebt dein Wiki auch einen Umzug bzw. eine Domainänderung.


Log in to reply