Berechtigungen zum Sehen/Bearbeiten der eigenen Stammdaten (Lösung gefunden)



  • Hallo

    Vielleicht bin ich zu blöd oder stehe sonst irgendwie auf dem Schlauch.
    Ich versuchre nun mal die neue Berechtigung aus, die mit der v3.47.0 dazu gekommen ist.

    Und zwar wollte ich einstellen, dass Benutzer ihre eigenen Daten nicht mehr ändern können. Wenn ich nun aber die Checkbox raus nehme (was meiner Meinung nach logisch wäre), kann ich die Daten immer noch bearbeiten. :-/

    Für mich ist diese Berechtigung eh nicht so logisch. Was ist, wenn ich die Checkbox bei "Stufe 2" und "Stufe 4" setze? Kann ich dann ausschliesslich diese beiden Stufen bearbeiten und 1 und 3 nicht? Logischer wären da Radiobuttons - falls überhaupt möglich.

    Gruss
    Robin


  • admin

    @rschi sagte in Berechtigungen zum Sehen/Bearbeiten der eigenen Stammdaten:

    Und zwar wollte ich einstellen, dass Benutzer ihre eigenen Daten nicht mehr ändern können. Wenn ich nun aber die Checkbox raus nehme (was meiner Meinung nach logisch wäre), kann ich die Daten immer noch bearbeiten. :-/

    Hat die Testperson ggf. über gruppen-interne Rechte die Berechtigung, alle Personen zu editieren?



  • @Andy Sorry, ich bin grad nicht mehr so regelmässig im Forum. Muss mit das bei Gelgegenheit nochmals genauer anschauen. Doch ich denke nicht, dass die Testperson diese Berechtigung hat.
    Aber mal schauen...



  • @Andy Ich weiss nicht mehr, mit wem ich damals getestet habe.
    Doch es könnte wirklich sein, dass du recht hast. Ich hatte in der Testumgebung mal neue Gruppen aufgebaut, durch die eine Person wirklich Leiter-Berechtigungen hatte und dadurch wahrscheinlich auch seine eigenen Daten bearbeiten konnte. Nun klappt es. :-)

    Vielen Dank!



  • Beim Leiter vom LP habe ich nun noch das Problem, dass er alle Personen im LP bearbeiten kann, dabei habe ich ihm die gruppen-interne Berechtigung "Alle Personen der Gruppe editieren" entzogen.

    Was könnte das noch sein?



  • Nach einem Blick in den Gruppen-internen Berechtigungen unter "Berechtigung für die untergeordneten Gruppen" konnte ich den Grund sehen und beheben.

    Somit hat es sich erledigt.